Silverfrost Logo About Us | Contact Us
 

See also: FTN95 Revision History

Version 4.8.2.0

  • New feature: Added use of gFortran to project configuration.

Version 4.8.1.0

  • Bug fix: Dependency checking was causing Plato to crash when adding multiple files and when removing files from a project.
  • Bug fix: "Goto Line" was crashing for module procedures with more than 32 characters.
  • New feature: FTN95 project compiler options extended to include new 64 bit options.

Version 4.8.0.0

  • New feature: In Fortran code, right click after "winio@(" to obtain a popup menu of winio@ format codes. Select a format from the menu in order to insert it in the code.
  • New feature: In Fortran code, right click before the closing square brackets in "winio@("%xx[...]" to obtain a popup list of available options for %xx (which represents any format code). Double click an option or press ENTER in order to insert an option in the code.

Version 4.7.5.0

  • SCC.chm and f77tut.chm now used in place of old .hlp files.
  • In the "Find and Replace" dialog and the "Replace with" box, use "&.." within the "replace" text to represent the "Find what" text. Alternatively use "&.clipName." to represent the clip named clipName in a category called "User". Use one form or the other at most once at a time.
  • Note: Notepad++ can display local strings of UTF-8 characters. To view these in Plato, use Notepad++ to copy the whole file to the clipboard, paste into an new file using Plato and then save using the "Advanced Save Options" and "UTF-8 without signature"

Version 4.7.4.0

  • Bug fix: Regression: Ctrl+C in runtime DOS box causes Plato to exit.

Version 4.7.3.0

  • Bug fix: Further work on "Rebuild Dependencies".

Version 4.7.2.0

  • New feature: Added "Debug x64" and "Checkmate x64" and launching of SDBG64. Checkmate only activates /debug for now.
  • New feature: Added relative path for files in "Project Explorer" window.
  • New feature: Added improved algorithm for building dependency order. Tested on project with 273 files. Absolute zero!
  • New feature: Added "refresh Plato" accelerator key Alt+R.
  • New feature: Added "make dirty" accelerator key Alt+D.
  • Bug fix: "New Folder" in "Project Explorer" window was not working correctly.
  • Bug fix: "Rebuild Dependencies" was failing for a large project because of a lost pointer.

Version 4.7.1.0

  • By default "Release x64" now targets FTN95 rather than gFortran. Can be configured to gFortran via the Options dialog

Version 4.7.0.0

  • New feature: "Find in files" now on a separate process thread so that the user can cancel via the Cancel button.
  • Bug fix: Failure of palette dialog now resolved.
  • Bug fix: Font face and size for source and output are now mirrored to avoid bug 4700. This avoids paint problems with "found" word and highlighting.
  • Bug fix: Fixed Clip dialog and Named Bookmark dialog so that the size data saved now uses dialog units.

Version 4.6.4.0

  • Bug fix: A new blank file could have garbage on the first line.
  • Bug fix: "Play Back Repeatedly" was locking Plato when "Find" not found message box was displayed.
  • Bug fix: "File open" was randomly failing because an internal buffer was not explicitly null terminated.
  • New feature: Added "Copy Full Path" and "Open Containing Folder" to tab context menu.
  • Bug fix: The use of user-defined language settings was raising an exception when exiting Plato.
  • Bug fix: Warning given on failure of palette dialog under Windows 8.

Version 4.6.3.0

  • New feature: The position of the FTN95.chm display window is now saved between calls and between Plato sessions.
  • Bug fix: Cancel Build was causing session to terminate.
  • Bug fix: Clicking on Console Close button was causing session to terminate.

Version 4.6.2.0

  • Bug fix: Tools menu item "Download/Locate gFortran" now dependent on ClearWin64.dll being on the PATH.

Version 4.6.1.0

  • New feature: Changed the default CLR_VER to 2.
  • New feature: 64 bit functionality is now dependent on ClearWin64.dll being on the PATH.

Version 4.6.0.0

  • Bug fix: Commands "goto" etc. in "Find Results 2" output were being applied to "Find Results 1".
  • Bug fix: Windows 7 taskbar behaviour was not programmed.
  • New feature: Added 64 bit gFortran functionality via new x64 platform.
  • New feature: Properties dialog for References is now platform dependent.

Version 4.5.1.0

  • New feature: Added /CFPP to project properties.
  • New feature: Modified F1 help to recognise ClearWin+ format codes. Also added "See also" links to FTN95.chm.
  • Bug fix: SPARAM must be an integer in Project Properties.
  • Bug fix: Build toolbar floating position was not restored between sessions.
  • Bug fix: Old project files without "Source Files" and "Include Files" headings were not being read correctly.

Version 4.5.0.0

  • New feature: Added item to main Window menu so that just two files can be tiled.
  • New feature: Resizing now includes retiling where appropriate.
  • New feature: Added buttons to Find-In-Files dialog so that previous results can be retrieved without searching again.
  • New feature: Added simple image editing and resource file dependency checking.
  • New feature: Upgraded Fortran 77 tutorial to 32bit help file.
  • New feature: Rebuild command enabled when there is no project.
  • New feature: By default, read all Plato application data from %APPDATA%\Silverfrost\FTN95\ with Plato.ini replacing Plato3.ini.
  • New feature: Changed to MFC file tabs and docking features.
  • New feature: Changed to dedicated Simdem for Silverfrost.
  • New feature: Added ClearWin+ and Simdem projects to New Project.
  • New feature: Added optional sample code for New Project.
  • New feature: Added new source file folder option to Project Explorer. Files can be dragged from one folder to another.
  • New feature: Added rename file option for source files in Project Explorer.
  • New feature: Added option to create a solution for multiple projects.
  • New feature: Non-project build now tests build dependency of included Fortran files (but these are not auto saved).
  • New feature: HTML files now have a web view for editing.
  • Bug fix: Added code to make toolbar gradient background refresh correctly on non-client paint.
  • Bug fix: Items were being removed from the recent file list when they still existed.
  • Bug fix: Increased buffer size on Open File dialog to allow reasonable number of multiple files.
  • Bug fix: Project "shell" did not use the current configuration. Now it does.
  • Bug fix: Command.OpenDosBox was not working.
  • Bug fix: File menu crashed for some 32bit Windows 7 systems.

Version 4.4.0.0

  • Bug fix: Undo and Redo now disabled when files becomes ReadOnly (whilst debugging). Improvement: A file is nolonger marked as modified after removing initial nulls. Warning given on Save.
  • Bug fix: Breakpoint not deleted when line is deleted.
  • Bug fix: Breakpoints not shown as grey line in SDBG.
  • Bug fix: "Step into" button not disabled for .NET and Release.
  • Bug fix: Vista style Open dialog does not show "Read only" etc. For the moment under Vista only the toolbar button displays the Vista style with no options.
  • New feature: Added -rlo SLINK option to Project "Reference" Properties.
  • New feature: Added code to use .NET version 2 when version 1.x is not installed etc.
  • Bug fix: Processing state not always reset when Build toolbar is not viewed.

Version 4.3.0.0

  • New feature: Colour printing added.
  • New feature: Full integration with SDBG added.
  • Bug fix: Lazy scrollbar in output window fixed.
  • Bug fix: Lost cursor found when using repeat Find and Find in Files.

Version 4.2.1.0

  • New feature: Direct access to ClearWin+ help added to help menu.

Version 4.2.0.0

  • New feature: Spy tool added.
  • New feature: Files that are nolonger existent are now removed from the recent file list.
  • New feature: Added /CLR_VER to project properties.
  • Bug fix: Restored compatibility with VS project file.

Version 4.1.1.0

  • Bug fix: Regression, change to UNICODE breaks reading ini file PATH from read-only Plato3.ini.
  • Bug fix: Error converting version string in Help About.

Version 4.0.1.0

  • New feature: Alt-X converts hex value with leading zero into corresponding Unicode character
  • Bug fix: Reference CopyLocal not saved for non-project
  • Bug fix: Project Explorer does not refresh on closing project
  • New feature: New option to Add Simdem references with associated functionality

Version 4.0.0.0

  • New feature: List of functions added to Goto dialog.
  • New feature: Time limit added to dependency checking.
  • Improvement: Source file names in the project file are now fully relative.
  • Bug fix: Buffer overflow (UNICODE only) when saving lines with more than 2K characters.
  • Bug fix: Windows 98 advanced menu problem - OS detected too late.
  • New feature: Comment out and comment in buttons now work for imported languages.
  • New feature: UNICODE is now the standard release.

Version 3.5.0.1

  • Bug fix: Clip library did not work for UNICODE.
  • Bug fix: Problems with using accelerator keys adopted as default by Plato.
  • New feature: Option to remove NULLs when opening a file.
  • New feature: Open project from list of recent projects.
  • New feature: View Windows Character Map.
  • Regression: Allow non-project references when not .NET.
  • New feature: Smart menu and toolbar backgrounds.

Version 3.5.0.0

  • New feature:Add files of given file type to project.
  • New feature:Added project type for static library (LIB).
  • New feature:Log file now created for each build command.
  • Improvement:Project ID now changes when changing from EXE to DLL etc.
  • Bug fix: Crashed when existing project opened via Explorer.
  • New feature:New command to replace existing tabs with spaces in current file.
  • Bug fix:Undo EXCHANGE should not test for tabs.

Version 3.4.0.1

  • Bug fix: Regression: File list order reverted.
  • Bug fix: Leak fixed due to calling DeleteNodeList at wrong point on exit from project.

Version 3.4.0.0

  • New feature:Apply to All button added to Properties dialog.
  • New feature:%t added to command options.
  • New feature:Clean after change of project options refined to avoid unreasonable rebuilding.
  • New feature:Build for .NET 2.0 or 1.1.
  • New feature:Fortran tutorials added.
  • Improved code:Link and file lists now kept in natural order. User may need to control link order.

Version 3.3.3.0

  • Bug fix: GetTarget() fixed so full path can be used for target.
  • Improved code: Improved node list added for project source files as well as references.
  • New feature:If user does not have write access to the compiler folder nor to the %SystemRoot% then find Plato3.ini on the PATH.
    Also administrator can replace Plato3.ini with file containing path of user Plato3.ini.

Version 3.3.2.0

  • New feature:References added to blank project

Version 3.3.1.0

  • New feature:Win32 references that are not on the path are now automatically copied to the project folder.
  • Bug fix:File save now checked for write error.

Version 3.3.0.0

  • Upgrade: User plug-in improvedt.

Version 3.2.1.0

  • Configuration change: /P6 is nolonger set on by default.
  • New feature:Option to switch off enhanced menus for Windows 2000/XP.

Version 3.2.0.0

  • New feature:Can now register .ftn95p with Explorer.
  • New feature:Build message output with successful compilation.
  • New feature:Can now comment-out HTML and uses old style C comments for selections that are not whole line.
  • Bug fix:Matching bracket overlay in wrong position when bracket is first character on a line.

Version 3.1.9.0

  • Bug fix:Full rebuild of dependencies needed when files are added or removed from a project.

Version 3.1.8.0

  • Bug fix:Regression - Height of some dialogs needs correction.
  • New feature:Auto indent works for more than one consecutive linefeed.
  • New feature:Ctrl+Click past end of a line gives "free" caret.

Version 3.1.7.0

  • New feature:New project option "Build Uses Active Source Only".

Version 3.1.6.0

  • Bug fix:File restore causes crash when file has been deleted.
  • Bug fix:Alt key does not always activate menu
  • Bug fix:/CVF_EXTERNAL removed because it is redundant.
  • New feature:New edit windows for Output and Find Results.
  • New feature:References can have STDCALL property for use with /IMPORT_LIB.

Version 3.1.5.0

  • Bug fix:Build etc. not available when no project files are open.
  • Bug fix:Cancel build does not break out of list of files to compile.
  • Bug fix:Project can be closed during build process causing fatal error.
  • Bug fix:Menu fonts do not work for Windows NT.
  • Bug fix:Scanning file handles is too slow.
  • Bug fix:Only one Monospaced font is displayed in Options dialog under Windows NT.
  • New feature:SCC and user plug-ins added.
  • Design change:Sets the current working directory to the project directory when running the target executable.

Version 3.1.4.0

  • Bug fix:Mouse down bug when opening a file
  • Bug fix:Splash window not always centred
  • Bug fix:Project Explorer window does not alway refresh

Version 3.1.3.0

  • Bug fix:GDI object leakage in enhanced menus and Output dialogs

Version 3.1.2.0

  • Bug fix:Problems opening remote project files
  • Bug fix:Character cell dimensions not updated after font change
  • New feature:Automatic file backup added.
  • New feature:Wildcards added to Find dialog
  • New feature:User defined syntax colouring added. Can also import syntax definition files.

Version 3.1.1.0

  • Bug fix:Margin after colour change, no OnIdle when toolbar hidden, etc.
  • New feature:VS behaviour for HOME added as an option
  • New feature:Option to show whitespace as symbols
  • New feature:Alt+Shift+Arrow gives column selectio
  • New feature:Basic method tips for standard and Salford routines added
  • New feature:User console commands attached to accelerator keys
  • Bug fix:Project file not in project folder could not be opened from Project Explorer
  • New feature:Open as binary added.
  • Bug fix:Compiler options that use quoted string parameters were not reloaded

Version 3.1.0.0 - Initial Full Release

  • Bug fix: Buffer overflow when using right click in the code view (report from Zahid Aziz).
  • New feature: Set project target and type across all configurations (for Wolf Krause).
  • New feature: Clip library.

Version 3.0.0.4 - Beta 4

  • Bug fix: Automatic bracket matching - adjacent brackets not highlighted
  • Bug fix: Spawned DOS box, Close box caused shut down. Now gives standard warning
  • Bug fix: Empty project target file name caused crash
  • New feature: Wild cards can now be used to open multiple files from the command line
  • New feature: S
Copyright © 1999-2017 Silverfrost Limited